# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\/saw:displayFormat>.(?!<\/saw:columnHeading>)"
test_str = ("<saw:column columnID=\"c83\" xsi:type=\"saw:regularColumn\"> \n"
"<saw:displayFormat>\n"
"<saw:formatSpec visibility=\"hidden\" suppress=\"default\" interaction=\"default\" wrapText=\"true\"/>\n"
"</saw:displayFormat> \n"
"<saw:columnHeading> \n"
"<saw:displayFormat>\n"
"<saw:formatSpec interaction=\"default\"/>\n"
"</saw:displayFormat>\n"
"</saw:columnHeading>\n"
" <saw:columnFormula>\n"
"<sawx:expr xsi:type=\"sawx:sqlExpression\">max(\"Supply Fact\".\"Count\")</sawx:expr></saw:columnFormula>\n"
"</saw:column>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.