#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:Server\sTime:\s?(.*)|Username:\s?(.*)|Important\sData:\s?(\w+))"
Local $sString = "$input = @"" & @CRLF & _
"Server Time: 4/13/2016 12:29 PM" & @CRLF & _
"Username: RBullwinkle" & @CRLF & _
"Lorem ipsum dolor Important Data: rosebud sit amet" & @CRLF & _
""@;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$input = @"" & @CRLF & _
"Lorem ipsum dolor Important Data: differentORder sit amet" & @CRLF & _
"Server Time: 2/29/2085 12:29 PM" & @CRLF & _
"Username: sweaver2112" & @CRLF & _
""@;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")