import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Server\\sTime:\\s?(.*)|Username:\\s?(.*)|Important\\sData:\\s?(\\w+))";
final String string = "$input = @\"\n"
+ "Server Time: 4/13/2016 12:29 PM\n"
+ "Username: RBullwinkle\n"
+ "Lorem ipsum dolor Important Data: rosebud sit amet\n"
+ "\"@;\n\n\n"
+ "$input = @\"\n"
+ "Lorem ipsum dolor Important Data: differentORder sit amet\n"
+ "Server Time: 2/29/2085 12:29 PM\n"
+ "Username: sweaver2112\n"
+ "\"@;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}