use strict;
my $str = '$input = @"
Server Time: 4/13/2016 12:29 PM
Username: RBullwinkle
Lorem ipsum dolor Important Data: rosebud sit amet
"@;
$input = @"
Lorem ipsum dolor Important Data: differentORder sit amet
Server Time: 2/29/2085 12:29 PM
Username: sweaver2112
"@;';
my $regex = qr/(?:Server\sTime:\s?(.*)|Username:\s?(.*)|Important\sData:\s?(\w+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}