// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:Server\sTime:\s?(.*)|Username:\s?(.*)|Important\sData:\s?(\w+))").unwrap();
let string = "$input = @\"
Server Time: 4/13/2016 12:29 PM
Username: RBullwinkle
Lorem ipsum dolor Important Data: rosebud sit amet
\"@;
$input = @\"
Lorem ipsum dolor Important Data: differentORder sit amet
Server Time: 2/29/2085 12:29 PM
Username: sweaver2112
\"@;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}