# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:Server\sTime:\s?(.*)|Username:\s?(.*)|Important\sData:\s?(\w+))"
test_str = ("$input = @\"\n"
"Server Time: 4/13/2016 12:29 PM\n"
"Username: RBullwinkle\n"
"Lorem ipsum dolor Important Data: rosebud sit amet\n"
"\"@;\n\n\n"
"$input = @\"\n"
"Lorem ipsum dolor Important Data: differentORder sit amet\n"
"Server Time: 2/29/2085 12:29 PM\n"
"Username: sweaver2112\n"
"\"@;")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.