const regex = /(?:Server\sTime:\s?(.*)|Username:\s?(.*)|Important\sData:\s?(\w+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Server\\sTime:\\s?(.*)|Username:\\s?(.*)|Important\\sData:\\s?(\\w+))', 'g')
const str = `\$input = @"
Server Time: 4/13/2016 12:29 PM
Username: RBullwinkle
Lorem ipsum dolor Important Data: rosebud sit amet
"@;
\$input = @"
Lorem ipsum dolor Important Data: differentORder sit amet
Server Time: 2/29/2085 12:29 PM
Username: sweaver2112
"@;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}