# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z0-9!#$%&'*\+=?^_`{|}~\-\s]+(?:\.[a-z0-9!#$%&'*\+=?^_`{|}~-]+)*(@|\s@\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\s)*\.(\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?/*bleep*/gmi;t' <<< "bonomi@spotify.com
bonomi @ spotify.com
test @ spotify.com
regularthing @ bla . com
lastname@domain . com
lastname@domain.com
lastname @domain.com
community.spotify.com
communityat.spotify.com
community at .spotify.com"