$re = '/[a-z0-9!#$%&\'*\+=?^_`{|}~\-\s]+(?:\.[a-z0-9!#$%&\'*\+=?^_`{|}~-]+)*(@|\s@\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\s)*\.(\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?/mi';
$str = 'bonomi@spotify.com
bonomi @ spotify.com
test @ spotify.com
regularthing @ bla . com
lastname@domain . com
lastname@domain.com
lastname @domain.com
community.spotify.com
communityat.spotify.com
community at .spotify.com';
$subst = "*bleep*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;