package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[a-z0-9!#$%&'*\+=?^_`{|}~\-\s]+(?:\.[a-z0-9!#$%&'*\+=?^_`{|}~-]+)*(@|\s@\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\s)*\.(\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?`)
var str = `bonomi@spotify.com
bonomi @ spotify.com
test @ spotify.com
regularthing @ bla . com
lastname@domain . com
lastname@domain.com
lastname @domain.com
community.spotify.com
communityat.spotify.com
community at .spotify.com`
var substitution = "*bleep*"
fmt.Println(re.ReplaceAllString(str, substitution))
}