const regex = /[a-z0-9!#$%&'*\+=?^_`{|}~\-\s]+(?:\.[a-z0-9!#$%&'*\+=?^_`{|}~-]+)*(@|\s@\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\s)*\.(\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z0-9!#$%&\'*\\+=?^_`{|}~\\-\\s]+(?:\\.[a-z0-9!#$%&\'*\\+=?^_`{|}~-]+)*(@|\\s@\\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\\s)*\\.(\\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?', 'gmi')
const str = `bonomi@spotify.com
bonomi @ spotify.com
test @ spotify.com
regularthing @ bla . com
lastname@domain . com
lastname@domain.com
lastname @domain.com
community.spotify.com
communityat.spotify.com
community at .spotify.com`;
const subst = `*bleep*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);