#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)[a-z0-9!#$%&'*\+=?^_`{|}~\-\s]+(?:\.[a-z0-9!#$%&'*\+=?^_`{|}~-]+)*(@|\s@\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\s)*\.(\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?"
Local $sString = "bonomi@spotify.com" & @CRLF & _
"bonomi @ spotify.com" & @CRLF & _
"test @ spotify.com" & @CRLF & _
"regularthing @ bla . com" & @CRLF & _
"lastname@domain . com" & @CRLF & _
"lastname@domain.com" & @CRLF & _
"lastname @domain.com" & @CRLF & _
"community.spotify.com" & @CRLF & _
"communityat.spotify.com" & @CRLF & _
"community at .spotify.com"
Local $sSubst = "*bleep*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)