# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z0-9!#$%&'*\+=?^_`{|}~\-\s]+(?:\.[a-z0-9!#$%&'*\+=?^_`{|}~-]+)*(@|\s@\s+)(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?((\s)*\.(\s)*))+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?"
test_str = ("bonomi@spotify.com\n"
"bonomi @ spotify.com\n"
"test @ spotify.com\n"
"regularthing @ bla . com\n"
"lastname@domain . com\n"
"lastname@domain.com\n"
"lastname @domain.com\n"
"community.spotify.com\n"
"communityat.spotify.com\n"
"community at .spotify.com")
subst = "*bleep*"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.