import re
regex = re.compile(r"^(((-?(\d{1,3})(\.\d+)?) (-?(\d{1,3})(\.\d+)?)),\s*){3,}$")
test_str = ("41.278198 95.914285,\n"
"41.278198 -95.914285,\n"
"41.278198 -95.914285,")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")