re = /^(((-?(\d{1,3})(\.\d+)?) (-?(\d{1,3})(\.\d+)?)),\s*){3,}$/
str = '41.278198 95.914285,
41.278198 -95.914285,
41.278198 -95.914285,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end