// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(((-?(\d{1,3})(\.\d+)?) (-?(\d{1,3})(\.\d+)?)),\s*){3,}$").unwrap();
let string = "41.278198 95.914285,
41.278198 -95.914285,
41.278198 -95.914285,";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}