import Foundation
let pattern = #"^(((-?(\d{1,3})(\.\d+)?) (-?(\d{1,3})(\.\d+)?)),\s*){3,}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
41.278198 95.914285,
41.278198 -95.914285,
41.278198 -95.914285,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}