using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3} ).+?(?=\1)";
string input = @"[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,878 ERROR [6] text text text
[11:28:31] : [Step 5/5] line text
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,959 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,961 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,962 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,966 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,967 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,968 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,969 WARN [6] Done";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}