import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2},\\d{3} ).+?(?=\\1)";
final String string = "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,878 ERROR [6] text text text\n"
+ "[11:28:31] : [Step 5/5] line text\n"
+ "[11:28:31] : [Step 5/5] more line text here\n"
+ "[11:28:31] : [Step 5/5] more line text here\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,959 WARN [6] Done\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,961 WARN [6] Done\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,962 WARN [6] Done\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,966 WARN [6] Done\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,967 WARN [6] Done\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,968 WARN [6] Done\n"
+ "[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,969 WARN [6] Done";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}