const regex = /(?s)(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3} ).+?(?=\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2},\\d{3} ).+?(?=\\1)', 'g')
const str = `[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,878 ERROR [6] text text text
[11:28:31] : [Step 5/5] line text
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,959 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,961 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,962 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,966 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,967 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,968 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,969 WARN [6] Done`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}