use strict;
my $str = '[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,878 ERROR [6] text text text
[11:28:31] : [Step 5/5] line text
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] more line text here
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,959 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,961 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,962 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,966 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,967 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,968 WARN [6] Done
[11:28:31] : [Step 5/5] 2022-02-02 11:28:31,969 WARN [6] Done';
my $regex = qr/(?s)(\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3} ).+?(?=\1)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}