#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ayam|nasi"
Local $sString = "#nasilemak sedap betul" & @CRLF & _
"Makan kena tunggu 1 jam baru sampai. #service slow" & @CRLF & _
"#jus mangga dia mengancam betul. sedap!" & @CRLF & _
"sambal #nasilemak dia power" & @CRLF & _
"kena datang awal" & @CRLF & _
"#beratur panjang. #ayamgoreng power" & @CRLF & _
"banyak pilihan #lauk" & @CRLF & _
"anda kena cuba #nasilemak ayam goreng dia" & @CRLF & _
"#nasilemak terbaik" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")