# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ayam|nasi"
test_str = ("#nasilemak sedap betul\n"
"Makan kena tunggu 1 jam baru sampai. #service slow\n"
"#jus mangga dia mengancam betul. sedap!\n"
"sambal #nasilemak dia power\n"
"kena datang awal\n"
"#beratur panjang. #ayamgoreng power\n"
"banyak pilihan #lauk\n"
"anda kena cuba #nasilemak ayam goreng dia\n"
"#nasilemak terbaik\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.