const regex = /ayam|nasi/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ayam|nasi', 'gm')
const str = `#nasilemak sedap betul
Makan kena tunggu 1 jam baru sampai. #service slow
#jus mangga dia mengancam betul. sedap!
sambal #nasilemak dia power
kena datang awal
#beratur panjang. #ayamgoreng power
banyak pilihan #lauk
anda kena cuba #nasilemak ayam goreng dia
#nasilemak terbaik
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}