using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ayam|nasi";
string input = @"#nasilemak sedap betul
Makan kena tunggu 1 jam baru sampai. #service slow
#jus mangga dia mengancam betul. sedap!
sambal #nasilemak dia power
kena datang awal
#beratur panjang. #ayamgoreng power
banyak pilihan #lauk
anda kena cuba #nasilemak ayam goreng dia
#nasilemak terbaik
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}