import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ayam|nasi";
final String string = "#nasilemak sedap betul\n"
+ "Makan kena tunggu 1 jam baru sampai. #service slow\n"
+ "#jus mangga dia mengancam betul. sedap!\n"
+ "sambal #nasilemak dia power\n"
+ "kena datang awal\n"
+ "#beratur panjang. #ayamgoreng power\n"
+ "banyak pilihan #lauk\n"
+ "anda kena cuba #nasilemak ayam goreng dia\n"
+ "#nasilemak terbaik\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}