using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?\/([^\/]+?\).+)$";
string substitution = @"ВАЛЕНОК$1";
string input = @"url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;
url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;
url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}