package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?\/([^\/]+?\).+)$`)
var str = `url(../img/repeat-elements/tpl-action-section_bg-1200.png) no-repeat 50%/1200px;
url(../img/pages/home/what-is_bg-1400.png) no-repeat 100% 50%/500px;
url(../img/blog/action/action_1-1400.png) no-repeat 100% 50%/500px;`
var substitution = "ВАЛЕНОК$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}