import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((^\\+44)|^(4{2})|(^0{2}4{2})|(^0)|)([123789])\\d{8,9}$";
final String string = "+44123456789\n"
+ "+441234567890\n"
+ "+44123456789\n"
+ "+441234567890\n"
+ "+447921040642\n"
+ "+441234567890\n"
+ "+44123456789\n"
+ "+44123456789\n"
+ "+441234567890\n"
+ "+44123456789\n"
+ "441234567890\n"
+ "44123456789\n"
+ "441234567890\n"
+ "447921040642\n"
+ "441234567890\n"
+ "44123456789\n"
+ "44123456789\n"
+ "441234567890\n"
+ "07921040642\n"
+ "0123456789\n"
+ "01234567890\n"
+ "0123456789\n"
+ "01234567890\n"
+ "01932867083\n"
+ "00441234567\n"
+ "0845121212\n"
+ "0044123456789\n"
+ "00441234567890\n"
+ "0123456789\n"
+ "01234567890\n"
+ "0123456789\n"
+ "01234567890\n"
+ "01932867083\n"
+ "00441234567\n"
+ "0044123456789\n"
+ "00441234567890\n"
+ "0044123456789\n"
+ "00441234567890\n"
+ "08006444454\n"
+ "4451925858\n"
+ "01420383091 \n"
+ "112222222\n"
+ "111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}