$re = '/^((^\+44)|^(4{2})|(^0{2}4{2})|(^0)|)([123789])\d{8,9}$/mi';
$str = '+44123456789
+441234567890
+44123456789
+441234567890
+447921040642
+441234567890
+44123456789
+44123456789
+441234567890
+44123456789
441234567890
44123456789
441234567890
447921040642
441234567890
44123456789
44123456789
441234567890
07921040642
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0845121212
0044123456789
00441234567890
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0044123456789
00441234567890
0044123456789
00441234567890
08006444454
4451925858
01420383091
112222222
111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);