import re
regex = re.compile(r"^((^\+44)|^(4{2})|(^0{2}4{2})|(^0)|)([123789])\d{8,9}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("+44123456789\n"
"+441234567890\n"
"+44123456789\n"
"+441234567890\n"
"+447921040642\n"
"+441234567890\n"
"+44123456789\n"
"+44123456789\n"
"+441234567890\n"
"+44123456789\n"
"441234567890\n"
"44123456789\n"
"441234567890\n"
"447921040642\n"
"441234567890\n"
"44123456789\n"
"44123456789\n"
"441234567890\n"
"07921040642\n"
"0123456789\n"
"01234567890\n"
"0123456789\n"
"01234567890\n"
"01932867083\n"
"00441234567\n"
"0845121212\n"
"0044123456789\n"
"00441234567890\n"
"0123456789\n"
"01234567890\n"
"0123456789\n"
"01234567890\n"
"01932867083\n"
"00441234567\n"
"0044123456789\n"
"00441234567890\n"
"0044123456789\n"
"00441234567890\n"
"08006444454\n"
"4451925858\n"
"01420383091 \n"
"112222222\n"
"111111111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")