import Foundation
let pattern = #"^((^\+44)|^(4{2})|(^0{2}4{2})|(^0)|)([123789])\d{8,9}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
+44123456789
+441234567890
+44123456789
+441234567890
+447921040642
+441234567890
+44123456789
+44123456789
+441234567890
+44123456789
441234567890
44123456789
441234567890
447921040642
441234567890
44123456789
44123456789
441234567890
07921040642
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0845121212
0044123456789
00441234567890
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0044123456789
00441234567890
0044123456789
00441234567890
08006444454
4451925858
01420383091
112222222
111111111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)