use strict;
my $str = '+44123456789
+441234567890
+44123456789
+441234567890
+447921040642
+441234567890
+44123456789
+44123456789
+441234567890
+44123456789
441234567890
44123456789
441234567890
447921040642
441234567890
44123456789
44123456789
441234567890
07921040642
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0845121212
0044123456789
00441234567890
0123456789
01234567890
0123456789
01234567890
01932867083
00441234567
0044123456789
00441234567890
0044123456789
00441234567890
08006444454
4451925858
01420383091
112222222
111111111';
my $regex = qr/^((^\+44)|^(4{2})|(^0{2}4{2})|(^0)|)([123789])\d{8,9}$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}