const regex = /\d/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d', '')
const str = `1a1.1a1af`;
const subst = `[/\d/]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);