// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d").unwrap();
let string = "1a1.1a1af";
let substitution = "[/\\d/]";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}