import Foundation
let pattern = #"\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1a1.1a1af"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[/\d/]"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}