#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|[-_])(\d+)(?=[_-]|[^\n\d_-]*$)"
Local $sString = "AB2C_192_A9" & @CRLF & _
"AB2C-192_A9" & @CRLF & _
"AB2C-192-A9" & @CRLF & _
"AB2C-192" & @CRLF & _
"ABC_192Z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")