using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|[-_])(\d+)(?=[_-]|[^\n\d_-]*$)";
string input = @"AB2C_192_A9
AB2C-192_A9
AB2C-192-A9
AB2C-192
ABC_192Z";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}