use strict;
my $str = 'AB2C_192_A9
AB2C-192_A9
AB2C-192-A9
AB2C-192
ABC_192Z';
my $regex = qr/(?:^|[-_])(\d+)(?=[_-]|[^\n\d_-]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}