const regex = /(?:^|[-_])(\d+)(?=[_-]|[^\n\d_-]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[-_])(\\d+)(?=[_-]|[^\\n\\d_-]*$)', 'gm')
const str = `AB2C_192_A9
AB2C-192_A9
AB2C-192-A9
AB2C-192
ABC_192Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}