re = /(?:^|[-_])(\d+)(?=[_-]|[^\n\d_-]*$)/m
str = 'AB2C_192_A9
AB2C-192_A9
AB2C-192-A9
AB2C-192
ABC_192Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end