import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[-_])(\\d+)(?=[_-]|[^\\n\\d_-]*$)";
final String string = "AB2C_192_A9\n"
+ "AB2C-192_A9\n"
+ "AB2C-192-A9\n"
+ "AB2C-192\n"
+ "ABC_192Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}