const regex = new RegExp('(?!\\+9936[0-9][\\s-]*|86[0-9])\\d{2}[\\s-]\\d{2}[\\s-]\\d{2}', 'gm')
const str = `Öý salgysy: Aşgabat şäheri, Bekrewe, Şkolnaýa köçesi, jaý 5 (ýazgyda: Aşgabat şäheri, Büzmeýin etraby, Zemlestroitelnaýa köçesi, jaý 9)
Tel: +99365 70-59-03 `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);