#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]{2,3}\d{2,3}\.[a-zA-Z]{3}\d{3}"
Local $sString = "rr01.tdw301" & @CRLF & _
"www101.red102" & @CRLF & _
"xxx000.xxx000" & @CRLF & _
"xx00.xxx000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")