const regex = /[a-zA-Z]{2,3}\d{2,3}\.[a-zA-Z]{3}\d{3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z]{2,3}\\d{2,3}\\.[a-zA-Z]{3}\\d{3}', 'g')
const str = `rr01.tdw301
www101.red102
xxx000.xxx000
xx00.xxx000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}