using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z]{2,3}\d{2,3}\.[a-zA-Z]{3}\d{3}";
string input = @"rr01.tdw301
www101.red102
xxx000.xxx000
xx00.xxx000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}