import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]{2,3}\\d{2,3}\\.[a-zA-Z]{3}\\d{3}";
final String string = "rr01.tdw301\n"
+ "www101.red102\n"
+ "xxx000.xxx000\n"
+ "xx00.xxx000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}