$re = '/[a-zA-Z]{2,3}\d{2,3}\.[a-zA-Z]{3}\d{3}/';
$str = 'rr01.tdw301
www101.red102
xxx000.xxx000
xx00.xxx000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);