import re
regex = re.compile(r"[a-zA-Z]{2,3}\d{2,3}\.[a-zA-Z]{3}\d{3}")
test_str = ("rr01.tdw301\n"
"www101.red102\n"
"xxx000.xxx000\n"
"xx00.xxx000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")