#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*(func1)(\()(.{1,64})(,\s*)(.{1,64}[A-Za-z\d])(\))+"
Local $sString = "func2(func1(ef5b, 7dbdd))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")